Archive

Archive for March, 2014

SharePoint 2013 Search – Display Error: The display template has an error…

 

Another silly one… If you are testing search while directly on the server, you may see the following issue:

Display Error: The display template had an error. You can correct it by fixing the template or by changing the display template used in either the Web Part properties or Result Types.

Automation server can’t create object (CoreRender: ~sitecollection/_catalogs/masterpage/Display Templates/Search/Item_CommonItem_Body.js)

SNAGHTML6dcdf049[4]

 

A simple fix is to add the url of the site to the Local Intranet zone or Trusted Sites zone in Internet Explorer.

SNAGHTML6dd2b710

 

From Internet Options, select the Security tab, select Local Intranet zone (or trusted sites zone). Click Sites, and add the site under Advanced.

Categories: SharePoint Tags:

User Profile Service stuck on starting

SharePoint Version: 2013

Build: (DEC CU)

There are many blogs out there dealing with this issue, as it’s not a new issue at all. However, I’m adding it here for my own record as I run in to it more than I would like. For the most part it’s related to permissions and the service will eventually return to stopped mode. However, there are situations where it truly is stuck on Starting.

If you find that the service is stuck on starting after trying various things like restarting the server, and waiting for days on end, then try the following script (replace <SERVERNAME> with the name of the server where the service instance is stuck on):

 

$n = Get-SPServiceInstance –Server <SERVERNAME>| ?{$_.TypeName -eq "User Profile Synchronization Service"}

Stop-SPServiceInstance $n.ID

Once the service instance stops, you can attempt to start it again from the services on server page.

Categories: SharePoint Tags: